Home > Not Working > Yamaha Rhino Digital Dash Not Working

Yamaha Rhino Digital Dash Not Working

Contents

in the manual called yamaha they had to do some searching on it but it turned out to be something to do with LOW VOLTAGE is what they told me they One if the terminals was backing out of the fuse block. To start viewing messages, select the forum that you want to visit from the selection below. Snowmobile Forum Snowmobile Brand Discussions Arctic Cat Sleds Ski-doo Polaris Sleds Yamaha Sleds Snowmobile General Discussions Vintage Sleds Performance http://tekspotting.com/not-working/yj-dash-lights-not-working.html

I've run them for a year or so with no problem. otherwise it could be the power in circuit to the gauge. The only tap in the factory wiring is a tap from the 12V accessory receptical which activates the aftermarket fuse block with the key in the ON position. Thanks so much for Website by Jamey Garrant (GEARSLAYER). -- Geared ---- test delete this style -- .Mobile Style. -- CND Garage English -- English (US)

vBulletin Security provided by vBSecurity v2.2.2 (Pro)

Yamaha Rhino Display Not Working

Sun Sep 15, 2013 12:40 am The steady state draw of the 35W HID's should not be causing any sort of problem. Up next EPS on a 2008 Rhino and works on Rhinos 04 and up - Duration: 12:14. Changed the fuse and it works fine. It would not be the inrush current because the relay is rated for 50 Amps for that.

The dash just lights up green nothing else? Watch Queue Queue __count__/__total__ Find out whyClose Correcting Rhino Speedometer Hunterworks1 SubscribeSubscribedUnsubscribe697697 Loading... Registered Users do not see these ads. RIP mbplayer View Public Profile Find all posts by mbplayer #2 06-01-2011, 05:25 PM boak Registered User Join Date: Apr 2005 Location: Manitoba Posts: 5,609 Thanks: 4,966 Thanked

My scenario: On last Saturday me and my Fiance went riding, she was on the Grizz I was on my Z400 well everything worked fine. Yamaha Rhino Wiring Diagram Please enter your desired user name, your email address and other required details in the form below. Sign in Transcript Statistics 3,057 views 2 Like this video? Google search VB search Search Home Forums Members' Forums Member Introductions RhinoTalk.net Police Blotter Member's Rides RhinoTalk.net News Yamaha Viking forum The Garage Yamaha Rhino General Discussions Yamaha Rhino Performance Discussions

Find a place on the back of the dash to jump a wire directly to ground on the battery.Do you have a volt meter ? I turn the knob to the HI position and the taillights stay illuminated as normal.The moment I plug in one or both of the HID lights, the dash goes dead just Join Date: Jul 2007 Posts: 2,065 Thanks: 203 Thanked 206 Times in 134 Posts Rep Power: 118 Location: Palmer, Alaska Quote #3 01-10-2009, 06:52 PM

QUOTE (08SEZ400 @ January What do you do for a living ?

Yamaha Rhino Wiring Diagram

Powered by vBulletin Version 3.8.7Copyright ©2000 - 2016, vBulletin Solutions, Inc. Thread Tools Show Printable Version Display Modes Linear Mode Switch to Hybrid Mode Switch to Threaded Mode Posting Rules You may not post new threads You may not post replies You Yamaha Rhino Display Not Working Human Verification In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in Yamaha Grizzly 660 Digital Display Not Working Human Verification In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in

The Display gets its power from the L/B wire coming out of the Starter Relay, all of the display info like speed, time, gas and Gear Indicator lights; they all get check over here New Yamaha SXS coming June 11 2013??.EZ Steer Power Steering installBUMPERS rhino.... Battery took full charge and was disconnected for an hour and still no luck on getting the display info back on, just the indigo light. The time now is 05:06 PM. Rhino 660 Speedometer Not Working

hillbrigger is offline Quote Quick Reply post #10 of 22 (permalink) Old 06-30-2008, 09:50 AM Thread Starter jasson450r Senior Member Join Date: Oct 2007 Location: isle Posts: 1,202 Thats Sign In Sign Up Forum Pictures Chat Browse Back Browse Calendar Staff Online Users Activity Back Activity All Activity Search Facebook Twitter Google search VB search Search Home Forums General mxrod is offline Quote Quick Reply Remove Advertisements Sponsored Links RhinoTalk.net Advertisement Reply Bookmarks Digg del.icio.us StumbleUpon Google vBulletin Message Cancel Changes Quick Reply The following errors occurred http://tekspotting.com/not-working/yamaha-gauges-not-working.html That one was purchased for tractors and trucks.

Our goal is to offer a place for Grizzly owners to discuss rides, events, mods, maintenance, purchasing, etc and offer help and assistance.Contact Us - Advertise - Yamaha Grizzly ATV Forum They are a single beam meaning that whenever you have the switch on HI or LO, the lights have power. Content on GrizzlyOwners.com is generated by its users and GrizzlyOwners.com is not in any way affiliated with Yamaha Motor Corporation, U.S.A.

For the best viewing experience please update your

B ut dont know?

Sat Sep 14, 2013 9:57 pm I knew you'd catch that!The relay on the right is the correct relay, and it is the failed relay. Yes, the OEM relay is SPST. EDIT: I think I miss read ya. If Yamaha skimped in it or somehow a lesser relay got put in along the way, it may be simply overstressed. I have HID headlights.

went from -14 degree wheather last week to now almost no snow left. Password Home Forum Rules Active Topics My Posts Register Today's Posts Search Grizzly Electrical & Lighting Discuss Grizzly electrical and lighting modifications here. So now for my current problem. weblink Working...

I'm going to start at the battery clean all connections and grounds i can find,then if that don't fix it cut open the wiring harness again an trace out each wire. Not to mention that you will get a better response! Yamaha and nearly every dealer out there will say tuff $hit. Thanks for any info you can help me with.

I did replace it with a known good relay to be sure. EDIT: its an 06 Grizzly 660 if that helps any. The Following 2 Users Say Thank You to 08SEZ400 For This Useful Post: dezz(09-26-2014), Greg1991(03-25-2016) Tjansen Join Date: Feb 2013 Age: 27 Posts: 1 Thanks: 0 Thanked 0 Times in 0 If that doesn't work bring it in.

dpod612 19,262 views 6:15 How to check the Rhino 700 TPS - Duration: 0:59. I have HID headlights. Sun Sep 15, 2013 3:12 pm ChrisH wrote:I repaired it.So, you left it connected to the negative battery terminal?_________________Two roads diverged in a wood,I took the one less traveled by....Oh, Oh Mine done basically the same thing, see may earllier post (instrument(dash)panel blank).My back light works but no numbers.Everything i tested says it's the dash.So i traded it out with my brother-in-laws.My

I just noticed the coincidental electrical problems when I tried to turn on the lights. My aftermarket accessories all functioned properly. Ive been crazy about quads and bikes since I was about 3 and ive always done my home work on them figuratively speaking. It's messy but worth it 2 years later now that I have 300+ hours of mud and dust.I was noticing that the contact lugs themselves did not seem to be greased?

Battery took full charge and was disconnected for an hour and still no luck on getting the display info back on, just the indigo light. #80 (permalink) 01-23-2012, 02:01 this is often the cause of the dead display.